Troubleshooting Global Protect VPN for Apple computers

Subject:
Troubleshooting Global Protect VPN for Apple Computers


Environment: 
Fresno State University, VPN, Apple, Security


Article Summary: 
This article provides troubleshooting tips for VPN on Apple Computers


Resolution: 
This article was provided by PaloAlto Networks for help with getting Global Protect to work on Apple Computers

Global Protect Agent stuck at connecting stage on MacOS

Global Protect Agent Global Protect App deployment

Symptom

New GlobalProtect deployment
GlobalProtect connectivity works fine from Windows
Issue is seen only on MacOS
GlobalProtect Agent stuck at connecting stage on MacOS with the following message:

"Some components of the GlobalProtect app could not be launched due to your operating system settings. This may cause some network traffic to be blocked. Please contact your IT administrator for assistance."

You will also see a message indicating System Extension Blocked

Cause
According to Technical Note TN2459 from Apple, "MacOS High Sierra 10.13 introduces a new feature that requires user approval before loading newly-installed third-party kernel extensions (KEXTs). "Additionally, Technical Note TN2459 from Apple indicates, "this feature enforces that only kernel extensions approved by the user will be loaded on a system."

When a request is made to load a KEXT that the user has not yet approved, the load request is denied and MacOS presents the alert with a System Extension Blocked message.

Resolution
Enable Palo Alto Networks as a trusted developer

From your Mac, launch System Preferences

Open the Security & Privacy preferences and then select General

Click the lock icon on the bottom left of the window to make changes and modify preferences

When prompted, enter your Mac User Name and Password and then unlock the preferences

Click Allow next to the message System software from developer Palo Alto Networks was blocked from loading.


Additional Information:

References: https://developer.apple.com/library/archive/technotes/tn2459/_index.html

Need additional information or assistance? Contact the Technology Service Desk at (559) 278-5000. 


TAGS: Fresno State University, VPN, Apple, Security


 

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